Iowa (US Central) data center outage

Incident Report for Anchor Hosting

Resolved

All affected sites have been restored.
Posted May 21, 2020 - 16:49 EDT

Identified

A few customer websites are currently offline due to an outage at Iowa data center. Kinsta is working to restore affected websites.
Posted May 21, 2020 - 15:14 EDT
This incident affected: Hosting.